#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<script[^>]*>([\s\S]+)(?=(\bABCDEF\b))([\s\S]+)<\/script>"
Local $sString = "<script XXXXXXXXX>" & @CRLF & _
"ZZZZZZ" & @CRLF & _
"ZZZZryZ" & @CRLF & _
"ZZZZZZ" & @CRLF & _
"ABCDEF" & @CRLF & _
"ZZZZZZ" & @CRLF & _
"ZZZZZZ" & @CRLF & _
"</script>"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)