$re = '/<script[^>]*>([\s\S]+)(?=(\bABCDEF\b))([\s\S]+)<\/script>/m';
$str = '<script XXXXXXXXX>
ZZZZZZ
ZZZZryZ
ZZZZZZ
ABCDEF
ZZZZZZ
ZZZZZZ
</script>';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;