import re
regex = re.compile(r"^.*?Python Regular Expression.*?$(*SKIP)(*FAIL)|^.*?Python Proprietary.*?$(*SKIP)(*FAIL)|.*?Page \d+.*?$(*SKIP)(*FAIL)|^$(*SKIP)(*FAIL)|^.*?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("This module provides regular expression matching operations.\n\n"
"Regular expressions use the backslash character ('\\') to indicate special forms\n"
"or to allow special characters to be used without invoking their special\n"
"meaning.\n\n"
"Python Regular Expression 02 December 1999 \n\n"
" Python Proprietary \n\n"
"----------------------- Page 292-----------------------\n\n"
"PYTHON RE SPECIFICATION Version 2.7 [Vol 9, Part Q] page 983 \n\n"
"Python Regular Expression Specification \n\n"
"It is important to note that most regular expression operations are available as\n"
"module-level functions and RegexObject methods. The functions are shortcuts that\n"
"don’t require you to compile a regex object first, but miss some fine-tuning\n"
"parameters.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")