const regex = /(?!.*[DFIOQU])[A-VXY][0-9][A-Z].?[0-9][A-Z][0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*[DFIOQU])[A-VXY][0-9][A-Z].?[0-9][A-Z][0-9]', 'gm')
const str = `Valid
123 4th Street, Toronto, Ontario, M1A 1A1
12456 Pine Way, Montreal, Quebec H9Z 9Z9
Invalid
123 4th Street, Toronto, Ontario, Q1A 1A1
12456 Pine Way, Montreal, Quebec H9Z-9Z9
56 Winding Way, Thunder Bay, Ontario, D56 4A3
34 Cliff Drive, Bishop's Falls, Newfoundland B7E 4T
123 4th Street, Toronto, Ontario, M1A 1Q1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}