$re = '/(?!.*[DFIOQU])[A-VXY][0-9][A-Z].?[0-9][A-Z][0-9]/m';
$str = 'Valid
123 4th Street, Toronto, Ontario, M1A 1A1
12456 Pine Way, Montreal, Quebec H9Z 9Z9
Invalid
123 4th Street, Toronto, Ontario, Q1A 1A1
12456 Pine Way, Montreal, Quebec H9Z-9Z9
56 Winding Way, Thunder Bay, Ontario, D56 4A3
34 Cliff Drive, Bishop\'s Falls, Newfoundland B7E 4T
123 4th Street, Toronto, Ontario, M1A 1Q1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);