$re = '~<(\w++)>(?:[^<>]|(?R))*+</\1>~i';
$str = '<TAG>one<TAG>two</TAG>one</TAG> foo bar <TAG>one<TAG>two<TAG>two</TAG></TAG><TAG>two</TAG>one</TAG> baz <tag> <tag></tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);