re = /<(\w++)>(?:[^<>]|(?R))*+<\/\1>/i
str = '<TAG>one<TAG>two</TAG>one</TAG> foo bar <TAG>one<TAG>two<TAG>two</TAG></TAG><TAG>two</TAG>one</TAG> baz <tag> <tag></tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end