package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[.*?])\|(.*)\|(Description:.*)`)
var str = `[Testing.User]|Info:([Testing.Info]|Name:([System.String]|Matt)|Age:([System.Int32]|21))|Description:([System.String]|This is some description)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}