$re = '/(?<!\..*)(\d)(?=(?:\d{3})+(?:\.|$))/m';
$str = '100
1000
10000
100000
1000000
100000000.000100010001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);