re = /(?<!\..*)(\d)(?=(?:\d{3})+(?:\.|$))/m
str = '100
1000
10000
100000
1000000
100000000.000100010001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end