const regex = /(?<!-)\b(\d{4})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!-)\\b(\\d{4})\\b', 'gm')
const str = `2014
1106 2014 9899
11500
234-233-2014
234-234-1100
-1100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}