import re
regex = re.compile(r"(?<!-)\b(\d{4})\b", flags=re.MULTILINE)
test_str = ("2014\n"
"1106 2014 9899\n"
" 11500\n\n"
"234-233-2014\n"
"234-234-1100\n"
"-1100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")