package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)Name=".*" (.*)`)
var str = `'Other parts of the string Name="SomeRandomAmountOfCharacters" blah blah'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}