re = /(.*)Name=".*" (.*)/m
str = '\'Other parts of the string Name="SomeRandomAmountOfCharacters" blah blah\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end