// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?P<show>[a-zA-Z1-9\.\-]+[^\.])
\.[Ss]?(?P<season>\d{1,2})[EeXx](?P<episode>\d{1,2})
(\.(?P<title>[a-zA-Z1-9\.]+[^\.]))?
\.(?P<resolution>\d{3,4}p)
\.(?P<quality>[a-zA-Z\-]{1,6})
\.(?P<codec>[a-zA-Z0-9\.]+\d)
([\.\-](?P<team>.+))?
$").unwrap();
let string = "Person.of.Interest.S05E13.720p.HDTV.X264-DIMENSION
The.Big.Bang.Theory.S09E21.720p.HDTV.X264-DIMENSION[ettv]
Homeland.S05E11.Our.Man.in.Damascus.720p.WEB-DL.DD5.1.H264-NTb[rarbg]
limitless.s01e01.pilot.720p.webrip.hevc.x265.rmteam
vikings.s04e01.a.good.treason.720p.web.dl.hevc.x265.rmteam
Brooklyn.Nine-Nine.S03E23.720p.WEBRip.x264
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}