import Foundation
let pattern = #"""
^
(?P<show>[a-zA-Z1-9\.\-]+[^\.])
\.[Ss]?(?P<season>\d{1,2})[EeXx](?P<episode>\d{1,2})
(\.(?P<title>[a-zA-Z1-9\.]+[^\.]))?
\.(?P<resolution>\d{3,4}p)
\.(?P<quality>[a-zA-Z\-]{1,6})
\.(?P<codec>[a-zA-Z0-9\.]+\d)
([\.\-](?P<team>.+))?
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Person.of.Interest.S05E13.720p.HDTV.X264-DIMENSION
The.Big.Bang.Theory.S09E21.720p.HDTV.X264-DIMENSION[ettv]
Homeland.S05E11.Our.Man.in.Damascus.720p.WEB-DL.DD5.1.H264-NTb[rarbg]
limitless.s01e01.pilot.720p.webrip.hevc.x265.rmteam
vikings.s04e01.a.good.treason.720p.web.dl.hevc.x265.rmteam
Brooklyn.Nine-Nine.S03E23.720p.WEBRip.x264
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)