use strict;
my $str = '"some.key" = "A cool value.";
"some.other.key" = "A cool value with %@ chars and \\n. Another Thing.";
"key with escaped \\"quotes\\"" = "value";
"escaped.key" = "A cool \\"value\\".";
"multiline.key.value" = "1. First sentence is \\"cool\\"\\
2. Second sentence\\
3. Third sentence\\
4. Fourth sentence";
"some.key2" = "";
"" = "";';
my $regex = qr/^"(.+?)(?<!\\)"\s*=\s*"([\s\S]*?)(?<!\\)";/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}