$re = '/^"(.+?)(?<!\\\\)"\s*=\s*"([\s\S]*?)(?<!\\\\)";/m';
$str = '"some.key" = "A cool value.";
"some.other.key" = "A cool value with %@ chars and \\n. Another Thing.";
"key with escaped \\"quotes\\"" = "value";
"escaped.key" = "A cool \\"value\\".";
"multiline.key.value" = "1. First sentence is \\"cool\\"\\
2. Second sentence\\
3. Third sentence\\
4. Fourth sentence";
"some.key2" = "";
"" = "";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);