#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http|ftp|https):\/\/([\w\-_]+(?:(?:\.[\w\-_]+)+))([\w\-\.,@?^=%&:/~\+#]*[\w\-\@?^=%&/~\+#])?"
Local $sString = "http://myip.ms/browse/ip_ranges/1/ownerID/224218/ownerID_A/1/sort/1/asc/1#ip_ranges_tbl_top" & @CRLF & _
"" & @CRLF & _
"<script src="mraid.js"></script>" & @CRLF & _
"<img src="data:image/png,mone" style="display: none" onerror="" & @CRLF & _
" (function(self) {" & @CRLF & _
" setTimeout(function() {" & @CRLF & _
" var creative = 'GetRich';" & @CRLF & _
" var suffix = '';" & @CRLF & _
" var country = 'om';" & @CRLF & _
" var campaignId = 16492;" & @CRLF & _
" var mediatorUrl = 'https://tags.mli.me';" & @CRLF & _
"" & @CRLF & _
" // --- ----" & @CRLF & _
" var params={scriptId:'mone-tag-script-1',tagTimestamp: new Date().getTime(), tagId:(Math.floor(Math.random() * 10000))};" & @CRLF & _
" var req = document.createElement('script');" & @CRLF & _
" req.src = mediatorUrl + '/mediator/' + country + '/_/_/' + creative + '/452/' + campaignId + '?';" & @CRLF & _
" req.id ='mone-tag-script-1';" & @CRLF & _
" params.requestId = '%{${RequestID}}%';" & @CRLF & _
" params.placement = '%{${Placement}}%';" & @CRLF & _
" params.gclid = '%{${GoogleUserID}}%';" & @CRLF & _
"" & @CRLF & _
" if(!!suffix)" & @CRLF & _
" params['x-suffix'] = suffix;" & @CRLF & _
" for (var k in params) {" & @CRLF & _
" req.src += '&' + encodeURIComponent(k) + '=' + encodeURIComponent(params[k]);" & @CRLF & _
" }" & @CRLF & _
" if (!window.moneTags) window.moneTags = {};" & @CRLF & _
" if (!window.moneTags.beacons) window.moneTags.beacons = {};" & @CRLF & _
" window.moneTags.beacons[params.tagId] = {'transition':['%%CLICK_URL_ESC%%']};" & @CRLF & _
" document.head.appendChild(req);" & @CRLF & _
" }, 2000);" & @CRLF & _
" })(this);" & @CRLF & _
" "/>" & @CRLF & _
"<img src="https://imp.mli.me/api/track/impression?RequestID=%{${RequestID}}%&CreativeID=%{${CreativeID}}%&WinningPrice=%%WINNING_PRICE%%" width="1" height="1">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")