using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|ftp|https):\/\/([\w\-_]+(?:(?:\.[\w\-_]+)+))([\w\-\.,@?^=%&:/~\+#]*[\w\-\@?^=%&/~\+#])?";
string input = @"http://myip.ms/browse/ip_ranges/1/ownerID/224218/ownerID_A/1/sort/1/asc/1#ip_ranges_tbl_top
<script src=""mraid.js""></script>
<img src=""data:image/png,mone"" style=""display: none"" onerror=""
(function(self) {
setTimeout(function() {
var creative = 'GetRich';
var suffix = '';
var country = 'om';
var campaignId = 16492;
var mediatorUrl = 'https://tags.mli.me';
// --- ----
var params={scriptId:'mone-tag-script-1',tagTimestamp: new Date().getTime(), tagId:(Math.floor(Math.random() * 10000))};
var req = document.createElement('script');
req.src = mediatorUrl + '/mediator/' + country + '/_/_/' + creative + '/452/' + campaignId + '?';
req.id ='mone-tag-script-1';
params.requestId = '%{${RequestID}}%';
params.placement = '%{${Placement}}%';
params.gclid = '%{${GoogleUserID}}%';
if(!!suffix)
params['x-suffix'] = suffix;
for (var k in params) {
req.src += '&' + encodeURIComponent(k) + '=' + encodeURIComponent(params[k]);
}
if (!window.moneTags) window.moneTags = {};
if (!window.moneTags.beacons) window.moneTags.beacons = {};
window.moneTags.beacons[params.tagId] = {'transition':['%%CLICK_URL_ESC%%']};
document.head.appendChild(req);
}, 2000);
})(this);
""/>
<img src=""https://imp.mli.me/api/track/impression?RequestID=%{${RequestID}}%&CreativeID=%{${CreativeID}}%&WinningPrice=%%WINNING_PRICE%%"" width=""1"" height=""1"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}