using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test-[^p]-1234";
string input = @"test-q-1234
test-p-1234
test-o-1234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}