$re = '/^test-[^p]-1234/m';
$str = 'test-q-1234
test-p-1234
test-o-1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);