package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([\p{L}\d_]+)`)
var str = `#جافا #Java #JAVA3 #جافا3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}