#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-*] ?([^-*].*?) ?[-*]"
Local $sString = "The Zen of Python, by Tim Peters" & @CRLF & _
"" & @CRLF & _
"Beautiful is better than ugly." & @CRLF & _
"Explicit is better than implicit." & @CRLF & _
"Simple is better than complex." & @CRLF & _
"Complex is better than complicated." & @CRLF & _
"Flat is better than nested." & @CRLF & _
"Sparse is better than dense." & @CRLF & _
"Readability counts." & @CRLF & _
"Special cases aren't special enough to break the rules." & @CRLF & _
"Although practicality beats purity." & @CRLF & _
"Errors should never pass silently." & @CRLF & _
"Unless explicitly silenced." & @CRLF & _
"In the face of ambiguity, refuse the temptation to guess." & @CRLF & _
"There should be one-- and preferably only one --obvious way to do it." & @CRLF & _
"Although that way may not be obvious at first unless you're Dutch." & @CRLF & _
"Now is better than never." & @CRLF & _
"Although never is often better than *right* now." & @CRLF & _
"If the implementation is hard to explain, it's a bad idea." & @CRLF & _
"If the implementation is easy to explain, it may be a good idea." & @CRLF & _
"Namespaces are one honking great idea -- let's do more of those!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")