# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[-*] ?([^-*].*?) ?[-*]"
test_str = ("The Zen of Python, by Tim Peters\n\n"
"Beautiful is better than ugly.\n"
"Explicit is better than implicit.\n"
"Simple is better than complex.\n"
"Complex is better than complicated.\n"
"Flat is better than nested.\n"
"Sparse is better than dense.\n"
"Readability counts.\n"
"Special cases aren't special enough to break the rules.\n"
"Although practicality beats purity.\n"
"Errors should never pass silently.\n"
"Unless explicitly silenced.\n"
"In the face of ambiguity, refuse the temptation to guess.\n"
"There should be one-- and preferably only one --obvious way to do it.\n"
"Although that way may not be obvious at first unless you're Dutch.\n"
"Now is better than never.\n"
"Although never is often better than *right* now.\n"
"If the implementation is hard to explain, it's a bad idea.\n"
"If the implementation is easy to explain, it may be a good idea.\n"
"Namespaces are one honking great idea -- let's do more of those!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.