package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\||^)(.*?):`)
var str = `Obj1:Val1|Obj2:Val2|Obj3:Val3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}