$re = '/(\||^)(.*?):/';
$str = 'Obj1:Val1|Obj2:Val2|Obj3:Val3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);