using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^!?.\n\r]*[!?.])(\w+:)(.*)$";
string input = @"Choose: blah blah blah 123 for 100'ish characters, this matches
Choose: blah blah blah 123! for 100'ish characters?, .this potential match fails for the ! ? and .";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}