const regex = /^(?![^!?.\n\r]*[!?.])(\w+:)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^!?.\\n\\r]*[!?.])(\\w+:)(.*)$', 'gm')
const str = `Choose: blah blah blah 123 for 100'ish characters, this matches
Choose: blah blah blah 123! for 100'ish characters?, .this potential match fails for the ! ? and .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}