using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[A-Z]{1,4}\b)
# Notice the matches below that don't fully match if these are NOT in reverse order:
(ACCS|ALLY|ALWY|AMBL|APP|ARC|ARTL|ARTY|AV|BA|BEND|BWLK|BVD|BR|BRAE|BRK|BROW|BYPA|BYWY|CSWY|CTR|CH|CIR|CCT|CRCS|CL|CON|CPS|CNR|CT|CTYD|COVE|CR|CRST|CRSS|CSAC|CUTT|DALE|DIP|DR|DVWY|EDGE|ELB|END|ENT|ESP|EXP|FAWY|FOLW|FTWY|FORM|FWY|FRTG|GAP|GDNS|GTE|GLDE|GLEN|GRA|GRN|GR|HTS|HIRD|HWY|HILL|INTG|JNC|KEY|LANE|LNWY|LINE|LINK|LKT|LOOP|MALL|MNDR|MEWS|MTWY|NOOK|OTLK|PDE|PWY|PASS|PSGE|PATH|PWAY|PIAZ|PLZA|PKT|PNT|PORT|PROM|QDRT|QYS|RMBL|REST|RTT|RDGE|RISE|RD|RTY|RTE|ROW|RUE|SVWY|SHUN|SPUR|SQ|ST|SBWY|TARN|TCE|THFR|TLWY|TOP|TOR|TRK|TRL|TURN|UPAS|VALE|VIAD|VIEW|VSTA|WALK|WKWY|WHRF|WYND)";
string input = @"Value
Val
ABCDE
ACCS
ALLY
ALWY
AMBL
APP
ARC
ARTL
ARTY
AV
BA
BEND
BWLK
BVD
BR
BRAE
BRK
BROW
BYPA
BYWY
CSWY
CTR
CH
CIR
CCT
CRCS
CL
CON
CPS
CNR
CT
CTYD
COVE
CR
CRST
CRSS
CSAC
CUTT
DALE
DIP
DR
DVWY
EDGE
ELB
END
ENT
ESP
EXP
FAWY
FOLW
FTWY
FORM
FWY
FRTG
GAP
GDNS
GTE
GLDE
GLEN
GRA
GRN
GR
HTS
HIRD
HWY
HILL
INTG
JNC
KEY
LANE
LNWY
LINE
LINK
LKT
LOOP
MALL
MNDR
MEWS
MTWY
NOOK
OTLK
PDE
PWY
PASS
PSGE
PATH
PWAY
PIAZ
PLZA
PKT
PNT
PORT
PROM
QDRT
QYS
RMBL
REST
RTT
RDGE
RISE
RD
RTY
RTE
ROW
RUE
SVWY
SHUN
SPUR
SQ
ST
SBWY
TARN
TCE
THFR
TLWY
TOP
TOR
TRK
TRL
TURN
UPAS
VALE
VIAD
VIEW
VSTA
WALK
WKWY
WHRF
WYND
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}