const regex = /^(?=[A-Z]{1,4}\b)
# Notice the matches below that don't fully match if these are NOT in reverse order:
(ACCS|ALLY|ALWY|AMBL|APP|ARC|ARTL|ARTY|AV|BA|BEND|BWLK|BVD|BR|BRAE|BRK|BROW|BYPA|BYWY|CSWY|CTR|CH|CIR|CCT|CRCS|CL|CON|CPS|CNR|CT|CTYD|COVE|CR|CRST|CRSS|CSAC|CUTT|DALE|DIP|DR|DVWY|EDGE|ELB|END|ENT|ESP|EXP|FAWY|FOLW|FTWY|FORM|FWY|FRTG|GAP|GDNS|GTE|GLDE|GLEN|GRA|GRN|GR|HTS|HIRD|HWY|HILL|INTG|JNC|KEY|LANE|LNWY|LINE|LINK|LKT|LOOP|MALL|MNDR|MEWS|MTWY|NOOK|OTLK|PDE|PWY|PASS|PSGE|PATH|PWAY|PIAZ|PLZA|PKT|PNT|PORT|PROM|QDRT|QYS|RMBL|REST|RTT|RDGE|RISE|RD|RTY|RTE|ROW|RUE|SVWY|SHUN|SPUR|SQ|ST|SBWY|TARN|TCE|THFR|TLWY|TOP|TOR|TRK|TRL|TURN|UPAS|VALE|VIAD|VIEW|VSTA|WALK|WKWY|WHRF|WYND)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[A-Z]{1,4}\\b)
# Notice the matches below that don\'t fully match if these are NOT in reverse order:
(ACCS|ALLY|ALWY|AMBL|APP|ARC|ARTL|ARTY|AV|BA|BEND|BWLK|BVD|BR|BRAE|BRK|BROW|BYPA|BYWY|CSWY|CTR|CH|CIR|CCT|CRCS|CL|CON|CPS|CNR|CT|CTYD|COVE|CR|CRST|CRSS|CSAC|CUTT|DALE|DIP|DR|DVWY|EDGE|ELB|END|ENT|ESP|EXP|FAWY|FOLW|FTWY|FORM|FWY|FRTG|GAP|GDNS|GTE|GLDE|GLEN|GRA|GRN|GR|HTS|HIRD|HWY|HILL|INTG|JNC|KEY|LANE|LNWY|LINE|LINK|LKT|LOOP|MALL|MNDR|MEWS|MTWY|NOOK|OTLK|PDE|PWY|PASS|PSGE|PATH|PWAY|PIAZ|PLZA|PKT|PNT|PORT|PROM|QDRT|QYS|RMBL|REST|RTT|RDGE|RISE|RD|RTY|RTE|ROW|RUE|SVWY|SHUN|SPUR|SQ|ST|SBWY|TARN|TCE|THFR|TLWY|TOP|TOR|TRK|TRL|TURN|UPAS|VALE|VIAD|VIEW|VSTA|WALK|WKWY|WHRF|WYND)', 'gm')
const str = `Value
Val
ABCDE
ACCS
ALLY
ALWY
AMBL
APP
ARC
ARTL
ARTY
AV
BA
BEND
BWLK
BVD
BR
BRAE
BRK
BROW
BYPA
BYWY
CSWY
CTR
CH
CIR
CCT
CRCS
CL
CON
CPS
CNR
CT
CTYD
COVE
CR
CRST
CRSS
CSAC
CUTT
DALE
DIP
DR
DVWY
EDGE
ELB
END
ENT
ESP
EXP
FAWY
FOLW
FTWY
FORM
FWY
FRTG
GAP
GDNS
GTE
GLDE
GLEN
GRA
GRN
GR
HTS
HIRD
HWY
HILL
INTG
JNC
KEY
LANE
LNWY
LINE
LINK
LKT
LOOP
MALL
MNDR
MEWS
MTWY
NOOK
OTLK
PDE
PWY
PASS
PSGE
PATH
PWAY
PIAZ
PLZA
PKT
PNT
PORT
PROM
QDRT
QYS
RMBL
REST
RTT
RDGE
RISE
RD
RTY
RTE
ROW
RUE
SVWY
SHUN
SPUR
SQ
ST
SBWY
TARN
TCE
THFR
TLWY
TOP
TOR
TRK
TRL
TURN
UPAS
VALE
VIAD
VIEW
VSTA
WALK
WKWY
WHRF
WYND
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}