import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4,5}-\\d{2,3}|\\w{3}\\d-\\d{2}|\\d{4,5}-\\w{1}\\d{2}|\\b|\\d{4}-\\w\\d{1}\\w|\\d{4,9}";
final String string = "11111-C00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}