const regex = new RegExp('\\d{4,5}-\\d{2,3}|\\w{3}\\d-\\d{2}|\\d{4,5}-\\w{1}\\d{2}|\\b|\\d{4}-\\w\\d{1}\\w|\\d{4,9}', '')
const str = `11111-C00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}