$re = '/^(070|080|081|090|091)[0-9]{8}$/i';
$str = '07098765432';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);