const regex = /(?<!\w)\[([\w-]+)=([\w-]+)(?:,[\w-]+=[\w-]+)*\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)\\[([\\w-]+)=([\\w-]+)(?:,[\\w-]+=[\\w-]+)*\\]', 'gm')
const str = `[tag=blue]Hello [tag2=red,tag3=blue]Good`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);