re = /(?<!\w)\[([\w-]+)=([\w-]+)(?:,[\w-]+=[\w-]+)*\]/m
str = '[tag=blue]Hello [tag2=red,tag3=blue]Good'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result