#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b((v.+)|(a|alpha.+)|(b|beta.+))?\s?(\d+\.)?(\d+\.)?(\*|\d+).+((a|alpha.+)|(b|beta.+))?"
Local $sString = "Version 1.2.3" & @CRLF & _
"Ver 6.5.3" & @CRLF & _
"V 9.1" & @CRLF & _
"V 2016-2-20" & @CRLF & _
"Version 19-03.1970" & @CRLF & _
"" & @CRLF & _
"Ver6.5.3" & @CRLF & _
"V9.1" & @CRLF & _
"V2016-2-20" & @CRLF & _
"Version19-03.1970" & @CRLF & _
"" & @CRLF & _
"version 1.2.3" & @CRLF & _
"ver 6.5.3" & @CRLF & _
"v 9.1" & @CRLF & _
"v 2016-2-20" & @CRLF & _
"version 19-03.1970" & @CRLF & _
"" & @CRLF & _
"ver6.5.3" & @CRLF & _
"v9.1" & @CRLF & _
"v2016-2-20" & @CRLF & _
"version19-03.1970" & @CRLF & _
"" & @CRLF & _
"6.5.3" & @CRLF & _
"9.1" & @CRLF & _
"2016-2-20" & @CRLF & _
"19-03.1970" & @CRLF & _
"" & @CRLF & _
"/****************************" & @CRLF & _
"* Sample Header Comment" & @CRLF & _
"* Created by Jane Programmer" & @CRLF & _
"* 2016-05-01" & @CRLF & _
"*" & @CRLF & _
"* Version 00.09 Beta" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"##############################" & @CRLF & _
"# Sample Comment Test 2" & @CRLF & _
"# Created by Joe Cool (Snoppy)" & @CRLF & _
"# 12/31/1979" & @CRLF & _
"# " & @CRLF & _
"# V8 (beta)" & @CRLF & _
"####" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"V8.45.32 beta" & @CRLF & _
"v78.14.01 Alpha" & @CRLF & _
"Alpha 781.54.1" & @CRLF & _
"" & @CRLF & _
"Beta 12.07.79" & @CRLF & _
"" & @CRLF & _
"a1.2.3" & @CRLF & _
"b4.5.6-99" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")