# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b((v.+)|(a|alpha.+)|(b|beta.+))?\s?(\d+\.)?(\d+\.)?(\*|\d+).+((a|alpha.+)|(b|beta.+))?"
test_str = ("Version 1.2.3\n"
"Ver 6.5.3\n"
"V 9.1\n"
"V 2016-2-20\n"
"Version 19-03.1970\n\n"
"Ver6.5.3\n"
"V9.1\n"
"V2016-2-20\n"
"Version19-03.1970\n\n"
"version 1.2.3\n"
"ver 6.5.3\n"
"v 9.1\n"
"v 2016-2-20\n"
"version 19-03.1970\n\n"
"ver6.5.3\n"
"v9.1\n"
"v2016-2-20\n"
"version19-03.1970\n\n"
"6.5.3\n"
"9.1\n"
"2016-2-20\n"
"19-03.1970\n\n"
"/****************************\n"
"* Sample Header Comment\n"
"* Created by Jane Programmer\n"
"* 2016-05-01\n"
"*\n"
"* Version 00.09 Beta\n"
"*/\n\n\n"
"##############################\n"
"# Sample Comment Test 2\n"
"# Created by Joe Cool (Snoppy)\n"
"# 12/31/1979\n"
"# \n"
"# V8 (beta)\n"
"####\n\n\n"
"V8.45.32 beta\n"
"v78.14.01 Alpha\n"
"Alpha 781.54.1\n\n"
"Beta 12.07.79\n\n"
"a1.2.3\n"
"b4.5.6-99\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.