const regex = /(?===)|(?<===)|\s|(?<!=)(?==)|(?<==)(?!=)|(?=\p{P})|(?<=\p{P})|(?=\+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?===)|(?<===)|\\s|(?<!=)(?==)|(?<==)(?!=)|(?=\\p{P})|(?<=\\p{P})|(?=\\+)', 'gm')
const str = `biscuit==cookie apple=fruit+-()`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);