re = /(?===)|(?<===)|\s|(?<!=)(?==)|(?<==)(?!=)|(?=\p{P})|(?<=\p{P})|(?=\+)/m
str = 'biscuit==cookie apple=fruit+-()'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result