$re = '/(?:[01]?\d|2[0-3]):[0-5]\d/';
$str = '23:44
START TIME: Mar. 3rd 2016 12:00am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);