re = /(?:[01]?\d|2[0-3]):[0-5]\d/
str = '23:44
START TIME: Mar. 3rd 2016 12:00am'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end