const regex = /(?<!color: )(#[0-9a-fA-F]{6})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!color: )(#[0-9a-fA-F]{6})', 'g')
const str = `text etxta #aaaaaa#bys1a asdasd
a#bbbbbbbys1a asdasd
test style="color: #cccccc"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}