$re = '/(?<!color: )(#[0-9a-fA-F]{6})/';
$str = 'text etxta #aaaaaa#bys1a asdasd
a#bbbbbbbys1a asdasd
test style="color: #cccccc"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);