#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(7656119)([0-9]{10})"
Local $sString = "http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx" & @CRLF & _
"//steamcommunity.com/profiles/76561198253871432" & @CRLF & _
"765611982538714325 - false" & @CRLF & _
"7656119825387143288 -false" & @CRLF & _
"7656119825387143 - false" & @CRLF & _
"76561198253871432 -true" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")