const regex = /\bA(?: \K)?\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bA(?: \\K)?\\S+', 'g')
const str = `Given: A23+ returns A23+
Given: A 23+ returns 23+
Given: A.rg23- returns A.rg23-
Given: A .rg23- returns .rg23-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}