using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\D*(?:7(?:\D*\d){12}|1(?:\D*\d){11})\D*$";
string input = @"a7a1a1a1a1a1a1a1a1a1a1a1a1
a1a3a3a3a3a3a3a3a3a3a3a3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}