$re = '/^\D*(?:7(?:\D*\d){12}|1(?:\D*\d){11})\D*$/m';
$str = 'a7a1a1a1a1a1a1a1a1a1a1a1a1
a1a3a3a3a3a3a3a3a3a3a3a3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);