const regex = new RegExp('(?P<remote_addr>((?:[0-9]{1,3}\\.){3}[0-9]{1,3})) (?P<dash>\\S+) (?P<remote_user>\\S+) \\[(?P<time_local>[\\w:\\/]+\\s[+|-]\\d{4})\\] \\"(?P<request>\\S+)\\s?(?P<path>\\S+)?\\s?(?P<protocol>\\S+)?\\" (?P<status_code>\\d{3}|-) (?P<body_bytes_sent>\\d+|-)\\s?\\"?(?P<http_referer>[^\\"]*)\\"?\\s\\"?(?P<http_user_agent>[^\\"]*)\\"\\s\\"?(?P<http_x_forwarded_for>[^\\"]*)', 'gm')
const str = `137.184.55.175 - 137.184.55.175 [28/Jul/2022:15:10:09 +0700] "GET /c/version.js HTTP/1.1" 404 18868 "lkk" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36" "agent"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}