use strict;
my $str = '137.184.55.175 - 137.184.55.175 [28/Jul/2022:15:10:09 +0700] "GET /c/version.js HTTP/1.1" 404 18868 "lkk" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36" "agent"';
my $regex = qr`(?P<remote_addr>((?:[0-9]{1,3}\.){3}[0-9]{1,3})) (?P<dash>\S+) (?P<remote_user>\S+) \[(?P<time_local>[\w:\/]+\s[+|-]\d{4})\] \"(?P<request>\S+)\s?(?P<path>\S+)?\s?(?P<protocol>\S+)?\" (?P<status_code>\d{3}|-) (?P<body_bytes_sent>\d+|-)\s?\"?(?P<http_referer>[^\"]*)\"?\s\"?(?P<http_user_agent>[^\"]*)\"\s\"?(?P<http_x_forwarded_for>[^\"]*)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}